To get email notification when someone adds to a thread you're following, click on the star in the thread's header and it will turn yellow; click again to turn it off. To edit your profile, click on the gear.
The Wall has a powerful search engine that will go all the way back to 2002. Use "quotation marks" around multiple-word searches. RIGHT-CLICK on the results and choose Open Link In New Window so you'll be able to get back to your results. Happy searching!
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.

Another GV problem

unclejohnunclejohn Posts: 548Member ✭✭
I have a Weil Mc. gv about 16 - 18 years old. A little less then a year ago [end of last heating season ] the boiler would call for heat and when the pressure light would come on the inducer motor would stop and then the cycle would repeat as many as 10 times or more and then it would go through a complete cycle and fire the boiler. I replaced the controller at that time and had no calls untill yesterday. Customer said it was doing the on off thing she could hear it happening all morning. Had her turn it off at power switch and back on and it fired. That was two days ago and all is still find as of this morning 2-28. Anybody else seen this? I had exact problem with different costumer over 4 years ago. replaced controller and never heard back. [Maybe she called somebody else]
· ·

Comments

  • TomTom Posts: 281Member
    I've seen it...

    It has only happened to me one time. It was actually 2 out of the 3 zone valves had bad end switches. So the customer had had water because that zone worked but when it wasn't calling for hot water the other 2 zones had a very, very weak end switch contact so it would call the boiler then turn it off then call then turn it off. Swapped to new erie heads life was good.
    · ·
  • unclejohnunclejohn Posts: 548Member ✭✭
    Thanks Tom

    I'll check that out. She does have honeywell zone valves. 3  In fact, hot water main and basement.
    · ·
  • Tim McElwainTim McElwain Posts: 3,144Member ✭✭✭
    Which Integrated Boiler control

    do you have on the GV?



    Have you gone through testing the differential pressure on the pressure switch? It should be 1.4" W.C.
    · ·
  • unclejohnunclejohn Posts: 548Member ✭✭
    Just checked

    My receipt and I bought the control last may from Somerville. I have not been out to the job. , The last call was a over the phone repair. sometimes the boiler just has

    to hear my voice and it straightens out. As I recall last May the light sequence was power of course Tstat purge or pressure. But as soon as pressure or purge lit the blower would just stop. I know I bypassed the tstat connection and it has worked fine up until a couple days ago when she called. I had her turn the 110v power switch off and back on, she was turning it off for a hour and then on and it just cycled. That time and now apparently its still working.  
    · ·
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!