To get email notification when someone adds to a thread you're following, click on the star in the thread's header and it will turn yellow; click again to turn it off. To edit your profile, click on the gear.
The Wall has a powerful search engine that will go all the way back to 2002. Use "quotation marks" around multiple-word searches. RIGHT-CLICK on the results and choose Open Link In New Window so you'll be able to get back to your results. Happy searching!
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.

Weil-McLain won't heat

Oly_MeganOly_Megan Posts: 3Member
HI-  I have a Weil-McLain natural gas furnace, installed around 1997.  Since the late fall, we have noticed that there hasn't been much heat coming from the baseboard heaters, but because we also have a gas fireplace, we didn't pay much attention until this weekend when the outside temp dropped below freezing.  Then we wanted all the rooms to have a heat source!



We checked out the furnace and it is completely cold.  We had a service person come out today.  He first tried replacing the ignitor because the board was flashing the  "vent" light, but that didn't fix the problem.  Now he thinks that the UTEC 1013-10 Integrated Boiler Control Board needs to be replaced. 



I think this is a really expensive part and the service person didn't seem very sure that replacing this part would fix the furnace.  Does anyone have any ideas for me?
·

Comments

  • JStarJStar Posts: 2,613Member ✭✭✭
    WM

    Whatis the model number? Does anything happen or run at all?
    - Joe Starosielec
    732-494-4357 ext. 2
    jstar.HVAC@gmail.com
    ·
  • Oly_MeganOly_Megan Posts: 3Member
    Model GV-4

    Ah, yes, I should have said - the Boiler model number is GV-4.



    We tried turning the power off and back on yesterday for about 5 minutes to reset the system.  At that time the Boiler Control Board went through its startup procedure a few times, but got stuck and started blinking the "vent" light.  We heard some pumps coming on.  We can't see the whether there is a flame in the ignitor - but because the service person swapped that part out today and the furnace still doesn't work, I'm going to go off the theory that the ignitor isn't the problem.
    ·
  • JStarJStar Posts: 2,613Member ✭✭✭
    Error code

    I din't see or remember any "vent" light code. Could it have been some other LED code?
    - Joe Starosielec
    732-494-4357 ext. 2
    jstar.HVAC@gmail.com
    ·
  • Oly_MeganOly_Megan Posts: 3Member
    Valve Light

    Looks like it is actually called "valve" light - sorry for the confusion.  I was going off memory and I should have verified before posting.
    ·
  • pappas911pappas911 Posts: 3Member
    furnace seems to work but boiler dosent

    all of a sudden our heat registers stopped getting warm and now the house is freezing,furnace seems to be working but not heating the house,thinking it might be the boiler,it makes weird sounds and dosent stay on long enough to do anything,
    ·
  • Tim McElwainTim McElwain Posts: 3,257Member ✭✭✭
    Need more information

    Is this also a Weil McLain GV model boiler?
    ·
  • icesailoricesailor Posts: 7,265Member ✭✭✭✭
    Sounds like a:

    Sounds like a Warm Air "Furnace" with a broken belt or motor ans no air flow.
    ·
  • pappas911pappas911 Posts: 3Member
    fixed

    it was a thermo Coupling , got it fixed :)
    ·
  • unclejohnunclejohn Posts: 652Member ✭✭✭
    That makes

    No sense at all.
    ·
  • pappas911pappas911 Posts: 3Member
    ok

    thermol it was ,whatever the spelling is
    ·
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!