To get email notification when someone adds to a thread you're following, click on the star in the thread's header and it will turn yellow; click again to turn it off. To edit your profile, click on the gear.
The Wall has a powerful search engine that will go all the way back to 2002. Use "quotation marks" around multiple-word searches. RIGHT-CLICK on the results and choose Open Link In New Window so you'll be able to get back to your results. Happy searching!
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.

Rinnai RU98i only works with cover off

Hi all,

I am a new owner of a rinnai RU98i. That doesn't ignite or ignites and then turns off after a few seconds. I have been getting the error codes 11 and 12. This doesnt seem to happen with the front cover off. I was wondering of there was a simple fix to this problem thanks.

This is a brand new unit and this issue has occurred since installation.

Thanks so much,



  • meplumbermeplumber Posts: 678Member
    Call the installer

    You need to get the installer back out there. He is responsible for the warranty of the unit.
  • Larry WeingartenLarry Weingarten Posts: 1,006Member ✭✭✭
    Long ago...

    ... I had a similar problem with a similar heater.  It turned out the metal cover shorted out part of the control circuitry when it was properly in place.  Have a look around for any wiring that might interfere with the cover.

    Yours,  Larry
  • JackJack Posts: 797Member ✭✭✭
    I would

    unplug the unit from 120 v. Remove th cover and see if all the exposed wires are securely fastened. Pay particular attention to the yellow wire to the flame rod. As well make sure the insulating boot is secure on the sparker. If that isn't in place it may be arcing to the cover. This is your installers job.
  • GordanGordan Posts: 891Member ✭✭
    I've seen this with plugged intake or vent

    If the unit can take interior combustion air with the cover off, this could explain it.
  • TheJazzManTheJazzMan Posts: 1Member
    Same Issue with E-110C

    I have a newly installed E-110CN that does the same thing. WOrks great with the cover off, but shortly after I put the cover on the unit either locks up or never ignites. The only way to get it going again is to reset it.

    In my case, I installed this unit myself and had my plumber hook up the gas, so calling the installer back isn’t an option.
  • JackJack Posts: 797Member ✭✭✭
    The cabinet

    on the RU model provides the combustion air chamber, meaning the CA enters thru the outer pipe in the concentric vent and then is pulled into the intake"horn" on the lower mid- rt side. Therefore, with 12 error code I would say that you need to check the vent to make sure the joints are secure and make sure you are getting no recirc of exhaust gases from the termination.

    On your 110 I would suggest that you pull the kill the power, remove the cover and check to make sure that all the electrical connections are secure. You should be able to see if you are pinching one or it is kinda sorta connected.
This discussion has been closed.


It looks like you're new here. If you want to get involved, click one of these buttons!